macOS で、Java の最新版 ( JRE 1.8 ) がインストールされているのに、以下のエラーで起動できません。

An error has occurred.
See the log file
・・・

macOS では JRE で起動できません(macOS における JRE 環境の不備のためです、Windows, Linux では JRE で起動できます)。

JDK をインストールすると起動できます。JDK の Mac OS X 版を以下のオラクルのページからダウンロードして、インストールしてから起動してください。

http://www.oracle.com/technetwork/java/javase/downloads/index.html